Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-1013

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-1013

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
06/07/2012
Created
07/25/2018
Added
12/12/2013
Modified
07/04/2017

Description

The check_1_6_dummy function in lib/kadm5/srv/svr_principal.c in kadmind in MIT Kerberos 5 (aka krb5) 1.8.x, 1.9.x, and 1.10.x before 1.10.2 allows remote authenticated administrators to cause a denial of service (NULL pointer dereference and daemon crash) via a KRB5_KDB_DISALLOW_ALL_TIX create request that lacks a password.

Solution(s)

  • suse-upgrade-krb5
  • suse-upgrade-krb5-32bit
  • suse-upgrade-krb5-client
  • suse-upgrade-krb5-client-debuginfo
  • suse-upgrade-krb5-debuginfo
  • suse-upgrade-krb5-debuginfo-32bit
  • suse-upgrade-krb5-debuginfo-x86
  • suse-upgrade-krb5-debuginfo-x86-debuginfo
  • suse-upgrade-krb5-debugsource
  • suse-upgrade-krb5-devel
  • suse-upgrade-krb5-devel-32bit
  • suse-upgrade-krb5-plugin-kdb-ldap
  • suse-upgrade-krb5-plugin-kdb-ldap-debuginfo
  • suse-upgrade-krb5-plugin-preauth-pkinit
  • suse-upgrade-krb5-plugin-preauth-pkinit-debuginfo
  • suse-upgrade-krb5-server
  • suse-upgrade-krb5-server-debuginfo
  • suse-upgrade-krb5-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;