Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-1586

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-1586

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
08/27/2012
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

mount.cifs in cifs-utils 2.6 allows local users to determine the existence of arbitrary files or directories via the file path in the second argument, which reveals their existence in an error message.

Solution(s)

  • suse-upgrade-cifs-mount
  • suse-upgrade-cifs-utils
  • suse-upgrade-cifs-utils-debuginfo
  • suse-upgrade-cifs-utils-debugsource
  • suse-upgrade-ldapsmb
  • suse-upgrade-libmsrpc
  • suse-upgrade-libmsrpc-devel
  • suse-upgrade-libsmbclient
  • suse-upgrade-libsmbclient-32bit
  • suse-upgrade-libsmbclient-64bit
  • suse-upgrade-libsmbclient-devel
  • suse-upgrade-libsmbclient-x86
  • suse-upgrade-libsmbsharemodes
  • suse-upgrade-libsmbsharemodes-devel
  • suse-upgrade-samba
  • suse-upgrade-samba-32bit
  • suse-upgrade-samba-64bit
  • suse-upgrade-samba-client
  • suse-upgrade-samba-client-32bit
  • suse-upgrade-samba-client-64bit
  • suse-upgrade-samba-client-x86
  • suse-upgrade-samba-doc
  • suse-upgrade-samba-krb-printing
  • suse-upgrade-samba-python
  • suse-upgrade-samba-vscan
  • suse-upgrade-samba-winbind
  • suse-upgrade-samba-winbind-32bit
  • suse-upgrade-samba-winbind-64bit
  • suse-upgrade-samba-winbind-x86
  • suse-upgrade-samba-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;