Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-3424

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-3424

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
08/08/2012
Created
07/25/2018
Added
12/12/2013
Modified
07/04/2017

Description

The decode_credentials method in actionpack/lib/action_controller/metal/http_authentication.rb in Ruby on Rails 3.x before 3.0.16, 3.1.x before 3.1.7, and 3.2.x before 3.2.7 converts Digest Authentication strings to symbols, which allows remote attackers to cause a denial of service by leveraging access to an application that uses a with_http_digest helper method, as demonstrated by the authenticate_or_request_with_http_digest method.

Solution(s)

  • suse-upgrade-rubygem-actionmailer-3_2
  • suse-upgrade-rubygem-actionmailer-3_2-doc
  • suse-upgrade-rubygem-actionpack-3_2
  • suse-upgrade-rubygem-actionpack-3_2-doc
  • suse-upgrade-rubygem-activemodel-3_2
  • suse-upgrade-rubygem-activemodel-3_2-doc
  • suse-upgrade-rubygem-activerecord-3_2
  • suse-upgrade-rubygem-activerecord-3_2-doc
  • suse-upgrade-rubygem-activeresource-3_2
  • suse-upgrade-rubygem-activeresource-3_2-doc
  • suse-upgrade-rubygem-activesupport-3_2
  • suse-upgrade-rubygem-activesupport-3_2-doc
  • suse-upgrade-rubygem-journey-1_0
  • suse-upgrade-rubygem-journey-1_0-doc
  • suse-upgrade-rubygem-journey-1_0-testsuite
  • suse-upgrade-rubygem-rails-3_2
  • suse-upgrade-rubygem-rails-3_2-doc
  • suse-upgrade-rubygem-railties-3_2
  • suse-upgrade-rubygem-railties-3_2-doc
  • suse-upgrade-rubygem-sprockets-2_1
  • suse-upgrade-rubygem-sprockets-2_1-doc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;