Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-3456

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-3456

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
08/20/2012
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Heap-based buffer overflow in the read function in filters/words/msword-odf/wv2/src/styles.cpp in the Microsoft import filter in Calligra 2.4.3 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted ODF style in an ODF document. NOTE: this is the same vulnerability as CVE-2012-3455, but it was SPLIT by the CNA even though Calligra and KOffice share the same codebase.

Solution(s)

  • suse-upgrade-calligra
  • suse-upgrade-calligra-braindump
  • suse-upgrade-calligra-devel
  • suse-upgrade-calligra-doc
  • suse-upgrade-calligra-flow
  • suse-upgrade-calligra-karbon
  • suse-upgrade-calligra-kexi
  • suse-upgrade-calligra-kexi-mssql-driver
  • suse-upgrade-calligra-kexi-mysql-driver
  • suse-upgrade-calligra-kexi-postgresql-driver
  • suse-upgrade-calligra-kexi-spreadsheet-import
  • suse-upgrade-calligra-kexi-xbase-driver
  • suse-upgrade-calligra-krita
  • suse-upgrade-calligra-kthesaurus
  • suse-upgrade-calligra-plan
  • suse-upgrade-calligra-sheets
  • suse-upgrade-calligra-stage
  • suse-upgrade-calligra-tools
  • suse-upgrade-calligra-words

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;