Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-5375

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-5375

Severity
4
CVSS
(AV:L/AC:H/Au:N/C:N/I:N/A:C)
Published
02/18/2013
Created
07/25/2018
Added
12/12/2013
Modified
06/21/2018

Description

The CRC32C feature in the Btrfs implementation in the Linux kernel before 3.8-rc1 allows local users to cause a denial of service (prevention of file creation) by leveraging the ability to write to a directory important to the victim, and creating a file with a crafted name that is associated with a specific CRC32C hash value.

Solution(s)

  • suse-upgrade-kernel-default
  • suse-upgrade-kernel-default-base
  • suse-upgrade-kernel-default-devel
  • suse-upgrade-kernel-default-extra
  • suse-upgrade-kernel-default-man
  • suse-upgrade-kernel-ec2
  • suse-upgrade-kernel-ec2-base
  • suse-upgrade-kernel-ec2-devel
  • suse-upgrade-kernel-pae
  • suse-upgrade-kernel-pae-base
  • suse-upgrade-kernel-pae-devel
  • suse-upgrade-kernel-pae-extra
  • suse-upgrade-kernel-ppc64
  • suse-upgrade-kernel-ppc64-base
  • suse-upgrade-kernel-ppc64-devel
  • suse-upgrade-kernel-source
  • suse-upgrade-kernel-syms
  • suse-upgrade-kernel-trace
  • suse-upgrade-kernel-trace-base
  • suse-upgrade-kernel-trace-devel
  • suse-upgrade-kernel-trace-extra
  • suse-upgrade-kernel-xen
  • suse-upgrade-kernel-xen-base
  • suse-upgrade-kernel-xen-devel
  • suse-upgrade-kernel-xen-extra
  • suse-upgrade-sles-for-vmware-release
  • suse-upgrade-xen-kmp-default
  • suse-upgrade-xen-kmp-trace

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;