Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2013-1655

Back to Search

SUSE Linux Security Vulnerability: CVE-2013-1655

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/20/2013
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Solution(s)

  • suse-upgrade-puppet
  • suse-upgrade-puppet-server

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;