Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2013-1872

Back to Search

SUSE Linux Security Vulnerability: CVE-2013-1872

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
08/19/2013
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

The Intel drivers in Mesa 8.0.x and 9.0.x allow context-dependent attackers to cause a denial of service (reachable assertion and crash) and possibly execute arbitrary code via vectors involving 3d graphics that trigger an out-of-bounds array access, related to the fs_visitor::remove_dead_constants function. NOTE: this issue might be related to CVE-2013-0796.

Solution(s)

  • suse-upgrade-libgbm-devel
  • suse-upgrade-libgbm-devel-32bit
  • suse-upgrade-libgbm1
  • suse-upgrade-libgbm1-32bit
  • suse-upgrade-libosmesa-devel
  • suse-upgrade-libosmesa-devel-32bit
  • suse-upgrade-libosmesa8
  • suse-upgrade-libosmesa8-32bit
  • suse-upgrade-libosmesa9
  • suse-upgrade-libosmesa9-32bit
  • suse-upgrade-libvdpau_nouveau
  • suse-upgrade-libvdpau_nouveau-32bit
  • suse-upgrade-libvdpau_r300
  • suse-upgrade-libvdpau_r300-32bit
  • suse-upgrade-libvdpau_r600
  • suse-upgrade-libvdpau_r600-32bit
  • suse-upgrade-libvdpau_softpipe
  • suse-upgrade-libvdpau_softpipe-32bit
  • suse-upgrade-libxatracker-devel
  • suse-upgrade-libxatracker1
  • suse-upgrade-libxvmc_nouveau
  • suse-upgrade-libxvmc_nouveau-32bit
  • suse-upgrade-libxvmc_r300
  • suse-upgrade-libxvmc_r300-32bit
  • suse-upgrade-libxvmc_r600
  • suse-upgrade-libxvmc_r600-32bit
  • suse-upgrade-libxvmc_softpipe
  • suse-upgrade-libxvmc_softpipe-32bit
  • suse-upgrade-mesa
  • suse-upgrade-mesa-32bit
  • suse-upgrade-mesa-devel
  • suse-upgrade-mesa-devel-32bit
  • suse-upgrade-mesa-libegl-devel
  • suse-upgrade-mesa-libegl-devel-32bit
  • suse-upgrade-mesa-libegl1
  • suse-upgrade-mesa-libegl1-32bit
  • suse-upgrade-mesa-libgl-devel
  • suse-upgrade-mesa-libgl-devel-32bit
  • suse-upgrade-mesa-libgl1
  • suse-upgrade-mesa-libgl1-32bit
  • suse-upgrade-mesa-libglapi-devel
  • suse-upgrade-mesa-libglapi-devel-32bit
  • suse-upgrade-mesa-libglapi0
  • suse-upgrade-mesa-libglapi0-32bit
  • suse-upgrade-mesa-libglesv1_cm-devel
  • suse-upgrade-mesa-libglesv1_cm-devel-32bit
  • suse-upgrade-mesa-libglesv1_cm1
  • suse-upgrade-mesa-libglesv1_cm1-32bit
  • suse-upgrade-mesa-libglesv2-2
  • suse-upgrade-mesa-libglesv2-2-32bit
  • suse-upgrade-mesa-libglesv2-devel
  • suse-upgrade-mesa-libglesv2-devel-32bit
  • suse-upgrade-mesa-libglu-devel
  • suse-upgrade-mesa-libglu-devel-32bit
  • suse-upgrade-mesa-libglu1
  • suse-upgrade-mesa-libglu1-32bit
  • suse-upgrade-mesa-libindirectgl-devel
  • suse-upgrade-mesa-libindirectgl-devel-32bit
  • suse-upgrade-mesa-libindirectgl1
  • suse-upgrade-mesa-libindirectgl1-32bit
  • suse-upgrade-mesa-x86
  • suse-upgrade-sle-sdk-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;