Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2014-9447: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2014-9447: SUSE Linux Security Advisory

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:P)
Published
01/02/2015
Created
07/25/2018
Added
12/18/2015
Modified
06/19/2021

Description

Directory traversal vulnerability in the read_long_names function in libelf/elf_begin.c in elfutils 0.152 and 0.161 allows remote attackers to write to arbitrary files to the root directory via a / (slash) in a crafted archive, as demonstrated using the ar program.

Solution(s)

  • suse-upgrade-elfutils
  • suse-upgrade-elfutils-lang
  • suse-upgrade-libasm-devel
  • suse-upgrade-libasm1
  • suse-upgrade-libasm1-32bit
  • suse-upgrade-libdw-devel
  • suse-upgrade-libdw1
  • suse-upgrade-libdw1-32bit
  • suse-upgrade-libdw1-x86
  • suse-upgrade-libebl-devel
  • suse-upgrade-libebl-plugins
  • suse-upgrade-libebl-plugins-32bit
  • suse-upgrade-libebl1
  • suse-upgrade-libebl1-32bit
  • suse-upgrade-libebl1-x86
  • suse-upgrade-libelf-devel
  • suse-upgrade-libelf1
  • suse-upgrade-libelf1-32bit
  • suse-upgrade-libelf1-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;