Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2014-9674: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2014-9674: SUSE Linux Security Advisory

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
02/08/2015
Created
07/25/2018
Added
12/18/2015
Modified
06/19/2021

Description

The Mac_Read_POST_Resource function in base/ftobjs.c in FreeType before 2.5.4 proceeds with adding to length values without validating the original values, which allows remote attackers to cause a denial of service (integer overflow and heap-based buffer overflow) or possibly have unspecified other impact via a crafted Mac font.

Solution(s)

  • suse-upgrade-freetype2
  • suse-upgrade-freetype2-32bit
  • suse-upgrade-freetype2-devel
  • suse-upgrade-freetype2-devel-32bit
  • suse-upgrade-freetype2-x86
  • suse-upgrade-ft2demos
  • suse-upgrade-ftbench
  • suse-upgrade-ftdiff
  • suse-upgrade-ftdump
  • suse-upgrade-ftgamma
  • suse-upgrade-ftgrid
  • suse-upgrade-ftinspect
  • suse-upgrade-ftlint
  • suse-upgrade-ftmulti
  • suse-upgrade-ftstring
  • suse-upgrade-ftvalid
  • suse-upgrade-ftview
  • suse-upgrade-libfreetype6
  • suse-upgrade-libfreetype6-32bit

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;