Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2015-1858: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2015-1858: SUSE Linux Security Advisory

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
05/12/2015
Created
07/25/2018
Added
12/18/2015
Modified
06/21/2021

Description

Multiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.

Solution(s)

  • suse-upgrade-libqt4
  • suse-upgrade-libqt4-32bit
  • suse-upgrade-libqt4-devel
  • suse-upgrade-libqt4-devel-doc
  • suse-upgrade-libqt4-devel-doc-data
  • suse-upgrade-libqt4-linguist
  • suse-upgrade-libqt4-private-headers-devel
  • suse-upgrade-libqt4-qt3support
  • suse-upgrade-libqt4-qt3support-32bit
  • suse-upgrade-libqt4-qt3support-x86
  • suse-upgrade-libqt4-sql
  • suse-upgrade-libqt4-sql-32bit
  • suse-upgrade-libqt4-sql-mysql
  • suse-upgrade-libqt4-sql-mysql-32bit
  • suse-upgrade-libqt4-sql-mysql-x86
  • suse-upgrade-libqt4-sql-postgresql
  • suse-upgrade-libqt4-sql-postgresql-32bit
  • suse-upgrade-libqt4-sql-postgresql-x86
  • suse-upgrade-libqt4-sql-sqlite
  • suse-upgrade-libqt4-sql-sqlite-32bit
  • suse-upgrade-libqt4-sql-sqlite-x86
  • suse-upgrade-libqt4-sql-unixodbc
  • suse-upgrade-libqt4-sql-unixodbc-32bit
  • suse-upgrade-libqt4-sql-unixodbc-x86
  • suse-upgrade-libqt4-sql-x86
  • suse-upgrade-libqt4-x11
  • suse-upgrade-libqt4-x11-32bit
  • suse-upgrade-libqt4-x11-x86
  • suse-upgrade-libqt4-x86
  • suse-upgrade-libqt5-qtbase-common-devel
  • suse-upgrade-libqt5-qtbase-devel
  • suse-upgrade-libqt5-qtbase-doc
  • suse-upgrade-libqt5-qtbase-private-headers-devel
  • suse-upgrade-libqt5bootstrap-devel-static
  • suse-upgrade-libqt5concurrent-devel
  • suse-upgrade-libqt5concurrent5
  • suse-upgrade-libqt5core-devel
  • suse-upgrade-libqt5core-private-headers-devel
  • suse-upgrade-libqt5core5
  • suse-upgrade-libqt5dbus-devel
  • suse-upgrade-libqt5dbus-private-headers-devel
  • suse-upgrade-libqt5dbus5
  • suse-upgrade-libqt5gui-devel
  • suse-upgrade-libqt5gui-private-headers-devel
  • suse-upgrade-libqt5gui5
  • suse-upgrade-libqt5network-devel
  • suse-upgrade-libqt5network-private-headers-devel
  • suse-upgrade-libqt5network5
  • suse-upgrade-libqt5opengl-devel
  • suse-upgrade-libqt5opengl-private-headers-devel
  • suse-upgrade-libqt5opengl5
  • suse-upgrade-libqt5openglextensions-devel-static
  • suse-upgrade-libqt5platformheaders-devel
  • suse-upgrade-libqt5platformsupport-devel-static
  • suse-upgrade-libqt5platformsupport-private-headers-devel
  • suse-upgrade-libqt5printsupport-devel
  • suse-upgrade-libqt5printsupport-private-headers-devel
  • suse-upgrade-libqt5printsupport5
  • suse-upgrade-libqt5sql-devel
  • suse-upgrade-libqt5sql-private-headers-devel
  • suse-upgrade-libqt5sql5
  • suse-upgrade-libqt5sql5-mysql
  • suse-upgrade-libqt5sql5-postgresql
  • suse-upgrade-libqt5sql5-sqlite
  • suse-upgrade-libqt5sql5-unixodbc
  • suse-upgrade-libqt5test-devel
  • suse-upgrade-libqt5test-private-headers-devel
  • suse-upgrade-libqt5test5
  • suse-upgrade-libqt5widgets-devel
  • suse-upgrade-libqt5widgets-private-headers-devel
  • suse-upgrade-libqt5widgets5
  • suse-upgrade-libqt5xml-devel
  • suse-upgrade-libqt5xml5
  • suse-upgrade-libqtwebkit-devel
  • suse-upgrade-libqtwebkit4
  • suse-upgrade-libqtwebkit4-32bit
  • suse-upgrade-libqtwebkit4-x86
  • suse-upgrade-qt4-x11-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;