Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2018-19211: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2018-19211: SUSE Linux Security Advisory

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
11/12/2018
Created
03/19/2019
Added
12/04/2018
Modified
10/22/2021

Description

In ncurses 6.1, there is a NULL pointer dereference at function _nc_parse_entry in parse_entry.c that will lead to a denial of service attack. The product proceeds to the dereference code path even after a "dubious character `*' in name or alias field" detection.

Solution(s)

  • suse-upgrade-libncurses5
  • suse-upgrade-libncurses5-32bit
  • suse-upgrade-libncurses6
  • suse-upgrade-libncurses6-32bit
  • suse-upgrade-ncurses-devel
  • suse-upgrade-ncurses-devel-32bit
  • suse-upgrade-ncurses-utils
  • suse-upgrade-ncurses5-devel
  • suse-upgrade-ncurses5-devel-32bit
  • suse-upgrade-tack
  • suse-upgrade-terminfo
  • suse-upgrade-terminfo-base
  • suse-upgrade-terminfo-iterm
  • suse-upgrade-terminfo-screen

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;