Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2019-15165: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2019-15165: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
10/03/2019
Created
10/17/2019
Added
10/16/2019
Modified
05/11/2021

Description

sf-pcapng.c in libpcap before 1.9.1 does not properly validate the PHB header length before allocating memory.

Solution(s)

  • suse-upgrade-libpcap-debugsource
  • suse-upgrade-libpcap-devel
  • suse-upgrade-libpcap-devel-32bit
  • suse-upgrade-libpcap-devel-static
  • suse-upgrade-libpcap1
  • suse-upgrade-libpcap1-32bit
  • suse-upgrade-libpcap1-32bit-debuginfo
  • suse-upgrade-libpcap1-debuginfo
  • suse-upgrade-tcpdump

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;