Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2019-5057: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2019-5057: SUSE Linux Security Advisory

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
07/02/2019
Created
09/07/2019
Added
09/06/2019
Modified
10/22/2021

Description

An exploitable code execution vulnerability exists in the PCX image-rendering functionality of SDL2_image 2.0.4. A specially crafted PCX image can cause a heap overflow, resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.

Solution(s)

  • suse-upgrade-libsdl2_image-2_0-0
  • suse-upgrade-libsdl2_image-2_0-0-32bit
  • suse-upgrade-libsdl2_image-devel
  • suse-upgrade-libsdl2_image-devel-32bit
  • suse-upgrade-libsdl_image-1_2-0
  • suse-upgrade-libsdl_image-1_2-0-32bit
  • suse-upgrade-libsdl_image-devel
  • suse-upgrade-libsdl_image-devel-32bit

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;