Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2021-22883: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2021-22883: SUSE Linux Security Advisory

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:C)
Published
02/26/2021
Created
03/02/2021
Added
02/28/2021
Modified
10/22/2021

Description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Solution(s)

  • suse-upgrade-nodejs10
  • suse-upgrade-nodejs10-devel
  • suse-upgrade-nodejs10-docs
  • suse-upgrade-nodejs12
  • suse-upgrade-nodejs12-devel
  • suse-upgrade-nodejs12-docs
  • suse-upgrade-nodejs14
  • suse-upgrade-nodejs14-devel
  • suse-upgrade-nodejs14-docs
  • suse-upgrade-npm10
  • suse-upgrade-npm12
  • suse-upgrade-npm14

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;