Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2021-22918: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2021-22918: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
07/07/2021
Created
07/17/2021
Added
07/15/2021
Modified
10/22/2021

Description

Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().

Solution(s)

  • suse-upgrade-nodejs10
  • suse-upgrade-nodejs10-devel
  • suse-upgrade-nodejs10-docs
  • suse-upgrade-nodejs12
  • suse-upgrade-nodejs12-devel
  • suse-upgrade-nodejs12-docs
  • suse-upgrade-nodejs14
  • suse-upgrade-nodejs14-devel
  • suse-upgrade-nodejs14-docs
  • suse-upgrade-npm10
  • suse-upgrade-npm12
  • suse-upgrade-npm14

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;