Rapid7 Vulnerability & Exploit Database

USN-2158-1: Linux kernel (Raring HWE) vulnerabilities

Back to Search

USN-2158-1: Linux kernel (Raring HWE) vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:N)
Published
10/10/2013
Created
07/25/2018
Added
04/08/2014
Modified
07/09/2020

Description

Off-by-one error in the get_prng_bytes function in crypto/ansi_cprng.c in the Linux kernel through 3.11.4 makes it easier for context-dependent attackers to defeat cryptographic protection mechanisms via multiple requests for small amounts of data, leading to improper management of the state of the consumed data.

Solution(s)

  • ubuntu-upgrade-linux-image-3-8-0-38-generic

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;