Rapid7 Vulnerability & Exploit Database

USN-2324-1: OpenStack Keystone vulnerabilities

Back to Search

USN-2324-1: OpenStack Keystone vulnerabilities

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
06/17/2014
Created
07/25/2018
Added
08/22/2014
Modified
07/09/2020

Description

OpenStack Identity (Keystone) before 2013.2.4, 2014.x before 2014.1.2, and Juno before Juno-2 allows remote authenticated trustees to gain access to an unauthorized project for which the trustor has certain roles via the project ID in a V2 API trust token request.

Solution(s)

  • ubuntu-upgrade-python-keystone

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;