Rapid7 Vulnerability & Exploit Database

USN-568-1: PostgreSQL vulnerabilities

Back to Search

USN-568-1: PostgreSQL vulnerabilities

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
01/09/2008
Created
07/25/2018
Added
05/06/2013
Modified
07/09/2020

Description

The DBLink module in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, 7.4 before 7.4.19, and 7.3 before 7.3.21, when local trust or ident authentication is used, allows remote attackers to gain privileges via unspecified vectors. NOTE: this issue exists because of an incomplete fix for CVE-2007-3278.

Solution(s)

  • ubuntu-upgrade-postgresql-8-2
  • ubuntu-upgrade-postgresql-pltcl-8-2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;