Rapid7 Vulnerability & Exploit Database

USN-689-1: Vinagre vulnerability

Back to Search

USN-689-1: Vinagre vulnerability

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
12/09/2008
Created
07/25/2018
Added
12/09/2008
Modified
07/09/2020

Description

Alfredo Ortega discovered a flaw in Vinagre's use of format strings. Aremote attacker could exploit this vulnerability if they tricked a userinto connecting to a malicious VNC server, or opening a specially craftedURI with Vinagre. In Ubuntu 8.04, it was possible to execute arbitrarycode with user privileges. In Ubuntu 8.10, Vinagre would simply abort,leading to a denial of service. The problem can be corrected by updating your system to the following package version: To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades. After a standard system upgrade you need to restart Vinagre to effectthe necessary changes. LP: 305623

Solution(s)

  • ubuntu-upgrade-vinagre

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;