Rapid7 Vulnerability & Exploit Database

USN-772-1: MPFR vulnerability

Back to Search

USN-772-1: MPFR vulnerability

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/03/2009
Created
07/25/2018
Added
05/06/2013
Modified
07/09/2020

Description

Multiple buffer overflows in GNU MPFR 2.4.0 allow context-dependent attackers to cause a denial of service (crash) via the (1) mpfr_snprintf and (2) mpfr_vsnprintf functions.

Solution(s)

  • ubuntu-upgrade-lib64mpfr1
  • ubuntu-upgrade-libmpfr1ldbl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;