Rapid7 Vulnerability & Exploit Database

USN-914-1: Linux kernel vulnerabilities

Back to Search

USN-914-1: Linux kernel vulnerabilities

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:C)
Published
02/12/2010
Created
07/25/2018
Added
05/06/2013
Modified
07/09/2020

Description

The pit_ioport_read function in the Programmable Interval Timer (PIT) emulation in i8254.c in KVM 83 does not properly use the pit_state data structure, which allows guest OS users to cause a denial of service (host OS crash or hang) by attempting to read the /dev/port file.

Solution(s)

  • ubuntu-upgrade-linux-image-2-6-24-27-386
  • ubuntu-upgrade-linux-image-2-6-24-27-generic
  • ubuntu-upgrade-linux-image-2-6-24-27-hppa32
  • ubuntu-upgrade-linux-image-2-6-24-27-hppa64
  • ubuntu-upgrade-linux-image-2-6-24-27-itanium
  • ubuntu-upgrade-linux-image-2-6-24-27-lpia
  • ubuntu-upgrade-linux-image-2-6-24-27-lpiacompat
  • ubuntu-upgrade-linux-image-2-6-24-27-mckinley
  • ubuntu-upgrade-linux-image-2-6-24-27-openvz
  • ubuntu-upgrade-linux-image-2-6-24-27-powerpc
  • ubuntu-upgrade-linux-image-2-6-24-27-powerpc-smp
  • ubuntu-upgrade-linux-image-2-6-24-27-powerpc64-smp
  • ubuntu-upgrade-linux-image-2-6-24-27-rt
  • ubuntu-upgrade-linux-image-2-6-24-27-server
  • ubuntu-upgrade-linux-image-2-6-24-27-sparc64
  • ubuntu-upgrade-linux-image-2-6-24-27-sparc64-smp
  • ubuntu-upgrade-linux-image-2-6-24-27-virtual
  • ubuntu-upgrade-linux-image-2-6-24-27-xen
  • ubuntu-upgrade-linux-image-2-6-27-17-generic
  • ubuntu-upgrade-linux-image-2-6-27-17-server
  • ubuntu-upgrade-linux-image-2-6-27-17-virtual
  • ubuntu-upgrade-linux-image-2-6-28-18-generic
  • ubuntu-upgrade-linux-image-2-6-28-18-imx51
  • ubuntu-upgrade-linux-image-2-6-28-18-iop32x
  • ubuntu-upgrade-linux-image-2-6-28-18-ixp4xx
  • ubuntu-upgrade-linux-image-2-6-28-18-lpia
  • ubuntu-upgrade-linux-image-2-6-28-18-server
  • ubuntu-upgrade-linux-image-2-6-28-18-versatile
  • ubuntu-upgrade-linux-image-2-6-28-18-virtual
  • ubuntu-upgrade-linux-image-2-6-31-109-imx51
  • ubuntu-upgrade-linux-image-2-6-31-20-386
  • ubuntu-upgrade-linux-image-2-6-31-20-generic
  • ubuntu-upgrade-linux-image-2-6-31-20-generic-pae
  • ubuntu-upgrade-linux-image-2-6-31-20-ia64
  • ubuntu-upgrade-linux-image-2-6-31-20-lpia
  • ubuntu-upgrade-linux-image-2-6-31-20-powerpc
  • ubuntu-upgrade-linux-image-2-6-31-20-powerpc-smp
  • ubuntu-upgrade-linux-image-2-6-31-20-powerpc64-smp
  • ubuntu-upgrade-linux-image-2-6-31-20-server
  • ubuntu-upgrade-linux-image-2-6-31-20-sparc64
  • ubuntu-upgrade-linux-image-2-6-31-20-sparc64-smp
  • ubuntu-upgrade-linux-image-2-6-31-20-virtual
  • ubuntu-upgrade-linux-image-2-6-31-212-dove
  • ubuntu-upgrade-linux-image-2-6-31-212-dove-z0
  • ubuntu-upgrade-linux-image-2-6-31-305-ec2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;