Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3491-1 (CVE-2014-3209): ldns vulnerabilities

Back to Search

Ubuntu: USN-3491-1 (CVE-2014-3209): ldns vulnerabilities

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
11/15/2014
Created
07/25/2018
Added
11/23/2017
Modified
11/23/2017

Description

The ldns-keygen tool in ldns 1.6.x uses the current umask to set the privileges of the private key, which might allow local users to obtain the private key by reading the file.

Solution(s)

  • ubuntu-upgrade-libldns1
  • ubuntu-upgrade-libldns2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;