Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3131-1 (CVE-2016-6823): ImageMagick vulnerabilities

Back to Search

Ubuntu: USN-3131-1 (CVE-2016-6823): ImageMagick vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
11/21/2016
Created
07/25/2018
Added
11/21/2016
Modified
06/10/2021

Description

Integer overflow in the BMP coder in ImageMagick before 7.0.2-10 allows remote attackers to cause a denial of service (crash) via crafted height and width values, which triggers an out-of-bounds write.

Solution(s)

  • ubuntu-upgrade-imagemagick
  • ubuntu-upgrade-imagemagick-6-q16
  • ubuntu-upgrade-libmagick-4
  • ubuntu-upgrade-libmagick-5
  • ubuntu-upgrade-libmagick-6-q16-5v5
  • ubuntu-upgrade-libmagickcore-6-q16-2
  • ubuntu-upgrade-libmagickcore-6-q16-2-extra
  • ubuntu-upgrade-libmagickcore4
  • ubuntu-upgrade-libmagickcore4-extra
  • ubuntu-upgrade-libmagickcore5
  • ubuntu-upgrade-libmagickcore5-extra

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;