Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3182-1 (CVE-2017-0358): NTFS-3G vulnerability

Back to Search

Ubuntu: USN-3182-1 (CVE-2017-0358): NTFS-3G vulnerability

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
02/01/2017
Created
07/25/2018
Added
02/02/2017
Modified
03/02/2020

Description

Jann Horn of Google Project Zero discovered that NTFS-3G, a read-write NTFS driver for FUSE, does not scrub the environment before executing modprobe with elevated privileges. A local user can take advantage of this flaw for local root privilege escalation.

Solution(s)

  • ubuntu-upgrade-ntfs-3g

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;