Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2018-1061): Python vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2018-1061): Python vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
04/26/2018
Created
03/19/2019
Added
11/15/2018
Modified
03/02/2020

Description

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method. An attacker could use this flaw to cause denial of service.

Solution(s)

  • ubuntu-upgrade-python2-7
  • ubuntu-upgrade-python2-7-minimal
  • ubuntu-upgrade-python3-4
  • ubuntu-upgrade-python3-4-minimal
  • ubuntu-upgrade-python3-5
  • ubuntu-upgrade-python3-5-minimal

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;