Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-5627-1 (CVE-2022-1586): PCRE vulnerabilities

Back to Search

Ubuntu: USN-5627-1 (CVE-2022-1586): PCRE vulnerabilities

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
05/16/2022
Created
09/26/2022
Added
09/23/2022
Modified
09/23/2022

Description

An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.

Solution(s)

  • ubuntu-upgrade-libpcre2-16-0
  • ubuntu-upgrade-libpcre2-32-0
  • ubuntu-upgrade-libpcre2-8-0
  • ubuntu-upgrade-libpcre2-posix2
  • ubuntu-upgrade-libpcre2-posix3
  • ubuntu-upgrade-pcre2-utils

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;