Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2022-22721): Apache HTTP Server vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2022-22721): Apache HTTP Server vulnerabilities

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
03/14/2022
Created
03/21/2022
Added
03/18/2022
Modified
03/24/2022

Description

If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

Solution(s)

  • ubuntu-upgrade-apache2
  • ubuntu-upgrade-apache2-bin

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;