Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-5462-1 (CVE-2022-28738): Ruby vulnerabilities

Back to Search

Ubuntu: USN-5462-1 (CVE-2022-28738): Ruby vulnerabilities

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/09/2022
Created
06/09/2022
Added
06/07/2022
Modified
06/07/2022

Description

A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

Solution(s)

  • ubuntu-upgrade-libruby2-5
  • ubuntu-upgrade-libruby2-7
  • ubuntu-upgrade-libruby3-0
  • ubuntu-upgrade-ruby2-5
  • ubuntu-upgrade-ruby2-7
  • ubuntu-upgrade-ruby3-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;