Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2022-2978): Linux kernel (GCP) vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2022-2978): Linux kernel (GCP) vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
08/24/2022
Created
10/03/2022
Added
10/01/2022
Modified
12/01/2022

Description

A flaw use after free in the Linux kernel NILFS file system was found in the way user triggers function security_inode_alloc to fail with following call to function nilfs_mdt_destroy. A local user could use this flaw to crash the system or potentially escalate their privileges on the system.

Solution(s)

  • ubuntu-upgrade-linux-image-4-15-0-1055-dell300x
  • ubuntu-upgrade-linux-image-4-15-0-1108-oracle
  • ubuntu-upgrade-linux-image-4-15-0-1121-raspi2
  • ubuntu-upgrade-linux-image-4-15-0-1129-kvm
  • ubuntu-upgrade-linux-image-4-15-0-1138-gcp
  • ubuntu-upgrade-linux-image-4-15-0-1139-snapdragon
  • ubuntu-upgrade-linux-image-4-15-0-1143-aws
  • ubuntu-upgrade-linux-image-4-15-0-1143-aws-hwe
  • ubuntu-upgrade-linux-image-4-15-0-197-generic
  • ubuntu-upgrade-linux-image-4-15-0-197-generic-lpae
  • ubuntu-upgrade-linux-image-4-15-0-197-lowlatency
  • ubuntu-upgrade-linux-image-4-4-0-1113-aws
  • ubuntu-upgrade-linux-image-4-4-0-1114-kvm
  • ubuntu-upgrade-linux-image-4-4-0-1151-aws
  • ubuntu-upgrade-linux-image-4-4-0-234-generic
  • ubuntu-upgrade-linux-image-4-4-0-234-lowlatency
  • ubuntu-upgrade-linux-image-5-15-0-1008-gkeop
  • ubuntu-upgrade-linux-image-5-15-0-1018-ibm
  • ubuntu-upgrade-linux-image-5-15-0-1018-intel-iotg
  • ubuntu-upgrade-linux-image-5-15-0-1018-raspi
  • ubuntu-upgrade-linux-image-5-15-0-1018-raspi-nolpae
  • ubuntu-upgrade-linux-image-5-15-0-1020-gke
  • ubuntu-upgrade-linux-image-5-15-0-1021-kvm
  • ubuntu-upgrade-linux-image-5-15-0-1022-gcp
  • ubuntu-upgrade-linux-image-5-15-0-1022-oracle
  • ubuntu-upgrade-linux-image-5-15-0-1023-aws
  • ubuntu-upgrade-linux-image-5-15-0-1023-azure
  • ubuntu-upgrade-linux-image-5-15-0-53-generic
  • ubuntu-upgrade-linux-image-5-15-0-53-generic-64k
  • ubuntu-upgrade-linux-image-5-15-0-53-generic-lpae
  • ubuntu-upgrade-linux-image-5-15-0-53-lowlatency
  • ubuntu-upgrade-linux-image-5-15-0-53-lowlatency-64k
  • ubuntu-upgrade-linux-image-5-17-0-1020-oem
  • ubuntu-upgrade-linux-image-5-4-0-1037-ibm
  • ubuntu-upgrade-linux-image-5-4-0-1050-bluefield
  • ubuntu-upgrade-linux-image-5-4-0-1057-gkeop
  • ubuntu-upgrade-linux-image-5-4-0-1074-raspi
  • ubuntu-upgrade-linux-image-5-4-0-1079-kvm
  • ubuntu-upgrade-linux-image-5-4-0-1087-gke
  • ubuntu-upgrade-linux-image-5-4-0-1087-oracle
  • ubuntu-upgrade-linux-image-5-4-0-1089-aws
  • ubuntu-upgrade-linux-image-5-4-0-1093-gcp
  • ubuntu-upgrade-linux-image-5-4-0-1095-azure
  • ubuntu-upgrade-linux-image-5-4-0-1095-azure-fde
  • ubuntu-upgrade-linux-image-5-4-0-132-generic
  • ubuntu-upgrade-linux-image-5-4-0-132-generic-lpae
  • ubuntu-upgrade-linux-image-5-4-0-132-lowlatency
  • ubuntu-upgrade-linux-image-aws
  • ubuntu-upgrade-linux-image-aws-hwe
  • ubuntu-upgrade-linux-image-aws-lts-18-04
  • ubuntu-upgrade-linux-image-aws-lts-20-04
  • ubuntu-upgrade-linux-image-aws-lts-22-04
  • ubuntu-upgrade-linux-image-azure
  • ubuntu-upgrade-linux-image-azure-fde
  • ubuntu-upgrade-linux-image-azure-lts-20-04
  • ubuntu-upgrade-linux-image-azure-lts-22-04
  • ubuntu-upgrade-linux-image-bluefield
  • ubuntu-upgrade-linux-image-dell300x
  • ubuntu-upgrade-linux-image-gcp
  • ubuntu-upgrade-linux-image-gcp-lts-18-04
  • ubuntu-upgrade-linux-image-gcp-lts-20-04
  • ubuntu-upgrade-linux-image-generic
  • ubuntu-upgrade-linux-image-generic-64k
  • ubuntu-upgrade-linux-image-generic-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-64k-hwe-22-04
  • ubuntu-upgrade-linux-image-generic-hwe-16-04
  • ubuntu-upgrade-linux-image-generic-hwe-18-04
  • ubuntu-upgrade-linux-image-generic-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-hwe-22-04
  • ubuntu-upgrade-linux-image-generic-lpae
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-18-04
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-22-04
  • ubuntu-upgrade-linux-image-generic-lts-xenial
  • ubuntu-upgrade-linux-image-gke
  • ubuntu-upgrade-linux-image-gke-5-15
  • ubuntu-upgrade-linux-image-gke-5-4
  • ubuntu-upgrade-linux-image-gkeop
  • ubuntu-upgrade-linux-image-gkeop-5-15
  • ubuntu-upgrade-linux-image-gkeop-5-4
  • ubuntu-upgrade-linux-image-ibm
  • ubuntu-upgrade-linux-image-ibm-lts-20-04
  • ubuntu-upgrade-linux-image-intel-iotg
  • ubuntu-upgrade-linux-image-kvm
  • ubuntu-upgrade-linux-image-lowlatency
  • ubuntu-upgrade-linux-image-lowlatency-64k
  • ubuntu-upgrade-linux-image-lowlatency-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-lowlatency-64k-hwe-22-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-16-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-18-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-20-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-22-04
  • ubuntu-upgrade-linux-image-lowlatency-lts-xenial
  • ubuntu-upgrade-linux-image-oem
  • ubuntu-upgrade-linux-image-oem-20-04
  • ubuntu-upgrade-linux-image-oem-22-04
  • ubuntu-upgrade-linux-image-oem-22-04a
  • ubuntu-upgrade-linux-image-oem-osp1
  • ubuntu-upgrade-linux-image-oracle
  • ubuntu-upgrade-linux-image-oracle-lts-18-04
  • ubuntu-upgrade-linux-image-oracle-lts-20-04
  • ubuntu-upgrade-linux-image-raspi
  • ubuntu-upgrade-linux-image-raspi-hwe-18-04
  • ubuntu-upgrade-linux-image-raspi-nolpae
  • ubuntu-upgrade-linux-image-raspi2
  • ubuntu-upgrade-linux-image-snapdragon
  • ubuntu-upgrade-linux-image-snapdragon-hwe-18-04
  • ubuntu-upgrade-linux-image-virtual
  • ubuntu-upgrade-linux-image-virtual-hwe-16-04
  • ubuntu-upgrade-linux-image-virtual-hwe-18-04
  • ubuntu-upgrade-linux-image-virtual-hwe-20-04
  • ubuntu-upgrade-linux-image-virtual-hwe-22-04
  • ubuntu-upgrade-linux-image-virtual-lts-xenial
  • ubuntu-upgrade-ubuntu

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;