Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-5509-1 (CVE-2022-30550): Dovecot vulnerability

Free InsightVM Trial No credit card necessary
Watch Demo See how it all works
Back to Search

Ubuntu: USN-5509-1 (CVE-2022-30550): Dovecot vulnerability

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/17/2022
Created
03/29/2023
Added
03/22/2023
Modified
03/22/2023

Description

An issue was discovered in the auth component in Dovecot 2.2 and 2.3 before 2.3.20. When two passdb configuration entries exist with the same driver and args settings, incorrect username_filter and mechanism settings can be applied to passdb definitions. These incorrectly applied settings can lead to an unintended security configuration and can permit privilege escalation in certain configurations. The documentation does not advise against the use of passdb definitions that have the same driver and args settings. One such configuration would be where an administrator wishes to use the same PAM configuration or passwd file for both normal and master users but use the username_filter setting to restrict which of the users is able to be a master user.

Solution(s)

  • ubuntu-upgrade-dovecot-core

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;