Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-5632-1 (CVE-2022-36087): OAuthLib vulnerability

Back to Search

Ubuntu: USN-5632-1 (CVE-2022-36087): OAuthLib vulnerability

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/09/2022
Created
09/26/2022
Added
09/23/2022
Modified
09/23/2022

Description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.

Solution(s)

  • ubuntu-upgrade-python3-oauthlib

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;