Rapid7 Vulnerability & Exploit Database

VideoLAN-SA-1102: Insufficient input validation in MKV demuxer

Back to Search

VideoLAN-SA-1102: Insufficient input validation in MKV demuxer

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
02/07/2011
Created
07/25/2018
Added
01/24/2013
Modified
05/27/2016

Description

demux/mkv/mkv.hpp in the MKV demuxer plugin in VideoLAN VLC media player 1.1.6.1 and earlier allows remote attackers to cause a denial of service (crash) and execute arbitrary commands via a crafted MKV (WebM or Matroska) file that triggers memory corruption, related to "class mismatching" and the MKV_IS_ID macro.

Solution(s)

  • videolan-vlc-upgrade-1_1_7

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;