Rapid7 Vulnerability & Exploit Database

vCenter server unauthenticated API endpoint vulnerability (VMSA-2021-0020) (CVE-2021-22011)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

vCenter server unauthenticated API endpoint vulnerability (VMSA-2021-0020) (CVE-2021-22011)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
09/21/2021
Created
02/03/2022
Added
09/22/2021
Modified
02/02/2022

Description

vCenter Server contains an unauthenticated API endpoint vulnerability in vCenter Server Content Library. A malicious actor with network access to port 443 on vCenter Server may exploit this issue to perform unauthenticated VM network setting manipulation.

Solution(s)

  • vmware-vcenter-cve-2021-22011-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;