Rapid7 Vulnerability & Exploit Database

Wireshark : CVE-2010-4538 : The ENTTEC dissector could overflow a buffer

Back to Search

Wireshark : CVE-2010-4538 : The ENTTEC dissector could overflow a buffer

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
01/07/2011
Created
07/25/2018
Added
10/04/2017
Modified
10/04/2017

Description

Buffer overflow in the sect_enttec_dmx_da function in epan/dissectors/packet-enttec.c in Wireshark 1.4.2 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted ENTTEC DMX packet with Run Length Encoding (RLE) compression.

Solution(s)

  • wireshark-upgrade-1_2_14
  • wireshark-upgrade-1_4_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;