appspider

System Requirements

Get Started

AppSpider Pro

Minimum System Requirements

Server Hardware Requirements

  • 4 Core CPU
  • 6 GB of RAM
  • 1 Network Interface
  • 500GB of Hard Drive Space

Software Requirements

One of the following operating systems:

  • Microsoft Windows Server 2003 SP1 (64-Bit)
  • Microsoft Windows Server 2008 Editions 
    (32-Bit/64-Bit)
  • Microsoft Windows Server 2008 R2 Editions (64-Bit)
  • Microsoft Windows Server 2012 R2 Editions (64-Bit)
  • Microsoft Windows Vista Ultimate, Professional, Enterprise, Home Premium (32-Bit/64-Bit)
  • Microsoft Windows 7 Ultimate, Professional, Enterprise, Home Premium (32-Bit/64-Bit)
  • Microsoft Windows 8 Professional (64-Bit)
  • Microsoft Windows 10 Pro/Enterprise
  • Microsoft Windows Server 2016

Additional Requirements

  • Microsoft .NET Framework 4.5 Redistributable Package
  • The latest version of Microsoft IE is required on the system with the scan engine. Some sites do not work with older versions of Microsoft IE
  • To successfully install, you will need more free hard disk space than the size of the installer itself. For more specific information about the space requirements, please contact support

AppSpider Enterprise

Minimum System Requirements

Server Hardware Requirements

  • 4GB of RAM
  • 1 Network Interface
  • 500+GB of Hard Drive Space

Software Requirements

One of the following operating systems:

  • Microsoft Windows Server 2012 (64-Bit)
  • Microsoft Windows Server 2016

A Web Application Server with the Following Components:

Microsoft ASP.NET Pages Microsoft Internet Information Services (IIS) 6.0 or later with the following:

  • ASP.NET Pages
  • Common Files
  • Simple Mail Transfer Protocol (SMTP) Service
  • World Wide Web Service

Server Databases

One of the Following Versions of Microsoft SQL Server:

  • Microsoft SQL Server 2008 Family including Express Edition
  • Microsoft SQL Server 2012 Family including Express Edition
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2016

Additional Requirements

Microsoft ASP.NET Pages Microsoft Internet Information Services (IIS) 6.0 or later with the following:

  • It is recommended to create SQL server account to be used by AppSpider Enterprise
  • It is recommended to install MS SQL Server Management Studio
  • To avoid IE 11 authentication issues .NET 4.5 should be installed on a web server box
  • To successfully install AppSpider Enterprise, you must have installed IIS 6.0 Management Compatibility on your IIS 7.0 machine. For more information, including instructions for installing IIS 6.0 Management Compatibility, please see the Microsoft Knowledge Base articles
  • Microsoft .NET Framework 4.0 Redistributable Package
  • Run the ASP.NET IIS Registration tool in order to register the .NET Framework with IIS and create application pools that use the .NET Framework 4
  • To successfully permit users to authenticate using Lightweight Directory Access Protocol AppSpider Enterprise supports integration with Active Directory and ADAM servers that have one of the following values of capabilities exposed by DCs on the supported Capabilities attribute of the rootDSE: '1.2.840.113556.1.4.800' or '1.2.840.113556.1.4.1851'
  • To successfully install, you will need more free hard disk space than the size of the installer itself. For more specific information about the space requirements, please contact support

Scan Engine System Requirements

Server Hardware Requirements

  • 4 Core CPU
  • 6 GB of RAM
  • 1 Network Interface
  • 100GB of Hard Drive Space

Software Requirements

One of the following operating systems:

  • Microsoft Windows Server 2003 SP1 (64-Bit)
  • Microsoft Windows Server 2008 Editions 
    (32-Bit/64-Bit)
  • Microsoft Windows Server 2008 R2 Editions (64-Bit)
  • Microsoft Windows Server 2012 R2 Editions (64-Bit)
  • Microsoft Windows Vista Ultimate, Professional, Enterprise, Home Premium (32-Bit/64-Bit)
  • Microsoft Windows 7 Ultimate, Professional, Enterprise, Home Premium (32-Bit/64-Bit)
  • Microsoft Windows 8 Professional (64-Bit)
  • Microsoft Windows 10 Pro/Enterprise
  • Microsoft Windows Server 2016

Additional Requirements

  • Microsoft .NET Framework 4.5 Redistributable Package
  • The latest version of Microsoft IE is required on the system with the scan engine. Some sites do not work with older versions of Microsoft IE
  • To successfully install, you will need more free hard disk space than the size of the installer itself. For more specific information about the space requirements, please contact support

Try AppSpider for Free

Download Now