Vulnerability & Exploit Database

Back to search

Dell OpenManage POST Request Heap Overflow (win32)

This module exploits a heap overflow in the Dell OpenManage Web Server (omws32.exe), versions 3.2-3.7.1. The vulnerability exists due to a boundary error within the handling of POST requests, where the application input is set to an overly long file name. This module will crash the web server, however it is likely exploitable under certain conditions.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

auxiliary/dos/http/dell_openmanage_post

Authors

  • aushack <patrick [at] osisecurity.com.au>

References

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use auxiliary/dos/http/dell_openmanage_post msf auxiliary(dell_openmanage_post) > show actions ...actions... msf auxiliary(dell_openmanage_post) > set ACTION <action-name> msf auxiliary(dell_openmanage_post) > show options ...show and set options... msf auxiliary(dell_openmanage_post) > run