Vulnerability & Exploit Database

Back to search

Unitrends UEB 9 http api/storage remote root

It was discovered that the api/storage web interface in Unitrends Backup (UB) before 10.0.0 has an issue in which one of its input parameters was not validated. A remote attacker could use this flaw to bypass authentication and execute arbitrary commands with root privilege on the target system.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/http/ueb9_api_storage

Authors

  • Cale Smith
  • Benny Husted
  • Jared Arave

References

Targets

  • UEB 9.*

Platforms

  • linux

Architectures

  • x86

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/http/ueb9_api_storage msf exploit(ueb9_api_storage) > show targets ...targets... msf exploit(ueb9_api_storage) > set TARGET <target-id> msf exploit(ueb9_api_storage) > show options ...show and set options... msf exploit(ueb9_api_storage) > exploit