Vulnerability & Exploit Database

Back to search

Oracle WebLogic wls-wsat Component Deserialization RCE

The Oracle WebLogic WLS WSAT Component is vulnerable to a XML Deserialization remote code execution vulnerability. Supported versions that are affected are 10.3.6.0.0, 12.1.3.0.0, 12.2.1.1.0 and 12.2.1.2.0. Discovered by Alexey Tyurin of ERPScan and Federico Dotta of Media Service. Please note that SRVHOST, SRVPORT, HTTP_DELAY, URIPATH and related HTTP Server variables are only used when executing a check and will not be used when executing the exploit itself.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/multi/http/oracle_weblogic_wsat_deserialization_rce

Authors

  • Kevin Kirsche <d3c3pt10n[AT]deceiveyour.team>
  • Luffin
  • Alexey Tyurin
  • Federico Dotta

References

Targets

  • Windows Command payload
  • Unix Command payload

Platforms

  • windows
  • unix

Architectures

  • cmd
  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/multi/http/oracle_weblogic_wsat_deserialization_rce msf exploit(oracle_weblogic_wsat_deserialization_rce) > show targets ...targets... msf exploit(oracle_weblogic_wsat_deserialization_rce) > set TARGET <target-id> msf exploit(oracle_weblogic_wsat_deserialization_rce) > show options ...show and set options... msf exploit(oracle_weblogic_wsat_deserialization_rce) > exploit

Related Vulnerabilities