Rapid7 Vulnerability & Exploit Database

Sflog! CMS 1.0 Arbitrary File Upload Vulnerability

Back to Search

Sflog! CMS 1.0 Arbitrary File Upload Vulnerability

Disclosed
07/06/2012
Created
05/30/2018

Description

This module exploits multiple design flaws in Sflog 1.0. By default, the CMS has a default admin credential of "admin:secret", which can be abused to access administrative features such as blogs management. Through the management interface, we can upload a backdoor that's accessible by any remote user, and then gain arbitrary code execution.

Author(s)

  • dun
  • sinn3r <sinn3r@metasploit.com>

Platform

Linux,PHP

Development

References

  • OSVDB-83767
  • EDB-19626

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/multi/http/sflog_upload_exec
msf exploit(sflog_upload_exec) > show targets
    ...targets...
msf exploit(sflog_upload_exec) > set TARGET < target-id >
msf exploit(sflog_upload_exec) > show options
    ...show and set options...
msf exploit(sflog_upload_exec) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;