Vulnerability & Exploit Database

Back to search

phpBB viewtopic.php Arbitrary Code Execution

This module exploits two arbitrary PHP code execution flaws in the phpBB forum system. The problem is that the 'highlight' parameter in the 'viewtopic.php' script is not verified properly and will allow an attacker to inject arbitrary code via preg_replace(). This vulnerability was introduced in revision 3076, and finally fixed in revision 5166. According to the "tags" within their tree, this corresponds to versions 2.0.4 through 2.0.15 (inclusive).

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/webapp/phpbb_highlight

Authors

  • valsmith <valsmith [at] metasploit.com>
  • hdm <x [at] hdm.io>
  • aushack <patrick [at] osisecurity.com.au>

References

Targets

  • Automatic
  • phpbb <=2.0.10
  • phpbb <=2.0.15

Platforms

  • unix

Architectures

  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/phpbb_highlight msf exploit(phpbb_highlight) > show targets ...targets... msf exploit(phpbb_highlight) > set TARGET <target-id> msf exploit(phpbb_highlight) > show options ...show and set options... msf exploit(phpbb_highlight) > exploit

Related Vulnerabilities