Vulnerability & Exploit Database

Back to search

Wordpress Front-end Editor File Upload

The WordPress Front-end Editor plugin contains an authenticated file upload vulnerability. An attacker can upload arbitrary files to the upload folder because the plugin uses its own file upload mechanism instead of the WordPress API, which incorrectly allows uploads of any file type.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/webapp/wp_frontend_editor_file_upload

Authors

  • Sammy
  • Roberto Soares Espreto <robertoespreto [at] gmail.com>

References

Targets

  • Front-End Editor 2.2.1

Platforms

  • php

Architectures

  • php

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/wp_frontend_editor_file_upload msf exploit(wp_frontend_editor_file_upload) > show targets ...targets... msf exploit(wp_frontend_editor_file_upload) > set TARGET <target-id> msf exploit(wp_frontend_editor_file_upload) > show options ...show and set options... msf exploit(wp_frontend_editor_file_upload) > exploit