Vulnerability & Exploit Database

Back to search

WordPress PHPMailer Host Header Command Injection

This module exploits a command injection vulnerability in WordPress version 4.6 with Exim as an MTA via a spoofed Host header to PHPMailer, a mail-sending library that is bundled with WordPress. A valid WordPress username is required to exploit the vulnerability. Additionally, due to the altered Host header, exploitation is limited to the default virtual host, assuming the header isn't mangled in transit. If the target is running Apache 2.2.32 or 2.4.24 and later, the server may have HttpProtocolOptions set to Strict, preventing a Host header containing parens from passing through, making exploitation unlikely.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/webapp/wp_phpmailer_host_header

Authors

  • Dawid Golunski
  • wvu <wvu [at] metasploit.com>

References

Targets

  • WordPress 4.6 / Exim

Platforms

  • linux

Architectures

  • x86
  • x64

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/wp_phpmailer_host_header msf exploit(wp_phpmailer_host_header) > show targets ...targets... msf exploit(wp_phpmailer_host_header) > set TARGET <target-id> msf exploit(wp_phpmailer_host_header) > show options ...show and set options... msf exploit(wp_phpmailer_host_header) > exploit

Related Vulnerabilities

Related Modules