Rapid7 Vulnerability & Exploit Database

HP Intelligent Management Center UAM Buffer Overflow

Back to Search

HP Intelligent Management Center UAM Buffer Overflow

Disclosed
08/29/2012
Created
05/30/2018

Description

This module exploits a remote buffer overflow in HP Intelligent Management Center UAM. The vulnerability exists in the uam.exe component, when using sprint in a insecure way for logging purposes. The vulnerability can be triggered by sending a malformed packet to the 1811/UDP port. The module has been successfully tested on HP iMC 5.0 E0101 and UAM 5.0 E0102 over Windows Server 2003 SP2 (DEP bypass).

Author(s)

  • e6af8de8b1d4b2b6d5ba2610cbf9cd38
  • sinn3r <sinn3r@metasploit.com>
  • juan vazquez <juan.vazquez@metasploit.com>

Platform

Windows

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/misc/hp_imc_uam
msf exploit(hp_imc_uam) > show targets
    ...targets...
msf exploit(hp_imc_uam) > set TARGET < target-id >
msf exploit(hp_imc_uam) > show options
    ...show and set options...
msf exploit(hp_imc_uam) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;