Vulnerability & Exploit Database

Back to search

PostgreSQL Database Name Command Line Flag Injection

This module can identify PostgreSQL 9.0, 9.1, and 9.2 servers that are vulnerable to command-line flag injection through CVE-2013-1899. This can lead to denial of service, privilege escalation, or even arbitrary code execution.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

auxiliary/scanner/postgres/postgres_dbname_flag_injection

Authors

  • hdm <x [at] hdm.io>

References

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use auxiliary/scanner/postgres/postgres_dbname_flag_injection msf auxiliary(postgres_dbname_flag_injection) > show actions ...actions... msf auxiliary(postgres_dbname_flag_injection) > set ACTION <action-name> msf auxiliary(postgres_dbname_flag_injection) > show options ...show and set options... msf auxiliary(postgres_dbname_flag_injection) > run

Related Vulnerabilities