Vulnerability & Exploit Database

Back to search

HP System Management Anonymous Access Code Execution

This module exploits an anonymous remote code execution on HP System Management 7.1.1 and earlier. The vulnerability exists when handling the iprange parameter on a request against /proxy/DataValidation. In order to work HP System Management must be configured with Anonymous access enabled.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/http/hp_system_management

Authors

  • agix

References

Targets

  • HP System Management 7.1.1 - Linux (CentOS)
  • HP System Management 6.3.0 - Linux (CentOS)

Platforms

  • linux

Architectures

  • x86

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/http/hp_system_management msf exploit(hp_system_management) > show targets ...targets... msf exploit(hp_system_management) > set TARGET <target-id> msf exploit(hp_system_management) > show options ...show and set options... msf exploit(hp_system_management) > exploit