Vulnerability & Exploit Database

Back to search

NETGEAR ReadyNAS Perl Code Evaluation

This module exploits a Perl code injection on NETGEAR ReadyNAS 4.2.23 and 4.1.11. The vulnerability exists on the web front end, specifically in the np_handler.pl component, due to an insecure usage of the eval() perl function. This module has been tested successfully on a NETGEAR ReadyNAS 4.2.23 Firmware emulated environment.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/http/netgear_readynas_exec

Authors

  • Craig Young
  • hdm <x [at] hdm.io>
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • NETGEAR ReadyNAS 4.2.23

Platforms

  • unix

Architectures

  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/http/netgear_readynas_exec msf exploit(netgear_readynas_exec) > show targets ...targets... msf exploit(netgear_readynas_exec) > set TARGET <target-id> msf exploit(netgear_readynas_exec) > show options ...show and set options... msf exploit(netgear_readynas_exec) > exploit