Vulnerability & Exploit Database

Back to search

Trend Micro InterScan Messaging Security (Virtual Appliance) Remote Code Execution

This module exploits the authentication bypass and command injection vulnerability together. Unauthenticated users can execute a terminal command under the context of the web server user. The specific flaw exists within the management interface, which listens on TCP port 443 by default. Trend Micro IMSVA product have widget feature which is implemented with PHP. Insecurely configured web server exposes diagnostic.log file, which leads to an extraction of JSESSIONID value from administrator session. Proxy.php files under the mod TMCSS folder takes multiple parameter but the process does not properly validate a user-supplied string before using it to execute a system call. Due to combination of these vulnerabilities, unauthenticated users can execute a terminal command under the context of the web server user.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/http/trendmicro_imsva_widget_exec

Authors

  • mr_me <mr_me [at] offensive-security.com>
  • Mehmet Ince <mehmet [at] mehmetince.net>

References

Targets

  • Automatic

Platforms

  • python

Architectures

  • python

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/http/trendmicro_imsva_widget_exec msf exploit(trendmicro_imsva_widget_exec) > show targets ...targets... msf exploit(trendmicro_imsva_widget_exec) > set TARGET <target-id> msf exploit(trendmicro_imsva_widget_exec) > show options ...show and set options... msf exploit(trendmicro_imsva_widget_exec) > exploit