Rapid7 Vulnerability & Exploit Database

Exim 4.87 - 4.91 Local Privilege Escalation

Back to Search

Exim 4.87 - 4.91 Local Privilege Escalation

Disclosed
06/05/2019
Created
08/23/2019

Description

This module exploits a flaw in Exim versions 4.87 to 4.91 (inclusive). Improper validation of recipient address in deliver_message() function in /src/deliver.c may lead to command execution with root privileges (CVE-2019-10149).

Author(s)

  • Qualys
  • Dennis Herrmann
  • Marco Ivaldi
  • Guillaume André

Platform

Linux

Architectures

x86, x64

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/local/exim4_deliver_message_priv_esc
msf exploit(exim4_deliver_message_priv_esc) > show targets
    ...targets...
msf exploit(exim4_deliver_message_priv_esc) > set TARGET < target-id >
msf exploit(exim4_deliver_message_priv_esc) > show options
    ...show and set options...
msf exploit(exim4_deliver_message_priv_esc) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;