Rapid7 Vulnerability & Exploit Database

Kloxo Local Privilege Escalation

Back to Search

Kloxo Local Privilege Escalation

Disclosed
09/18/2012
Created
05/30/2018

Description

Version 6.1.12 and earlier of Kloxo contain two setuid root binaries such as lxsuexec and lxrestart, allow local privilege escalation to root from uid 48, Apache by default on CentOS 5.8, the operating system supported by Kloxo. This module has been tested successfully with Kloxo 6.1.12 and 6.1.6.

Author(s)

  • HTP
  • juan vazquez <juan.vazquez@metasploit.com>

Platform

Linux

Architectures

x86

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/local/kloxo_lxsuexec
msf exploit(kloxo_lxsuexec) > show targets
    ...targets...
msf exploit(kloxo_lxsuexec) > set TARGET < target-id >
msf exploit(kloxo_lxsuexec) > show options
    ...show and set options...
msf exploit(kloxo_lxsuexec) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;