Vulnerability & Exploit Database

Back to search

Overlayfs Privilege Escalation

This module attempts to exploit two different CVEs related to overlayfs. CVE-2015-1328: Ubuntu specific -> 3.13.0-24 (14.04 default) < 3.13.0-55 3.16.0-25 (14.10 default) < 3.16.0-41 3.19.0-18 (15.04 default) < 3.19.0-21 CVE-2015-8660: Ubuntu: 3.19.0-18 < 3.19.0-43 4.2.0-18 < 4.2.0-23 (14.04.1, 15.10) Fedora: < 4.2.8 (vulnerable, un-tested) Red Hat: < 3.10.0-327 (rhel 6, vulnerable, un-tested)

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/local/overlayfs_priv_esc

Authors

  • h00die <mike [at] shorebreaksecurity.com>
  • rebel

References

Targets

  • CVE-2015-1328
  • CVE-2015-8660

Platforms

  • linux

Architectures

  • x86
  • x64

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/local/overlayfs_priv_esc msf exploit(overlayfs_priv_esc) > show targets ...targets... msf exploit(overlayfs_priv_esc) > set TARGET <target-id> msf exploit(overlayfs_priv_esc) > show options ...show and set options... msf exploit(overlayfs_priv_esc) > exploit

Related Vulnerabilities